Skip to main content
Avalara Help Center

Getting a "Microsoft.NET v2 and WSE 2 must be installed prior to using the Avalara AvaTax adapter" error when installing sage 100

Overview

I am installing Sage 100 and getting an error that 'Microsoft.NET and WSE 2 must be installed prior to using the Avalara AvaTax adapter.' We have Microsoft 3.5 installed, do I have to install the V2 version?

Environment

Sage 100

Resolution

  • You do have to install the Microsoft V2 version for Sage to install AvaTax correctly

  • If you have a later version (3.5 or later) on your server, you will have to enable the framework in Managed Services: 

    • In Server Manager, click Manage and then select Add Roles and Features to start the Add Roles and Features Wizard.
    • On the Select installation type screen, select Role-based or feature-based installation.
    • Select the target server.
    • On the Select features screen, check the box next to .Net Framework 3.5 Features. Expand the selection to confirm .net 2.0 is included.
    • On the Confirm installation selections screen, a warning will be displayed asking Do you need to specify an alternate source path?. If the target computer does not have access to the internet, you will need to select an installation path for your framework. 
    • Confirm, and reboot the server. 
    • Launch Sage 100.