Skip to main content
Avalara Help Center

Is Woo Commerce 2.4 supported by TaxNow?


You would like to know if Woo Commerce 2.4.8 is supported by TAXNOW.


Woo Commerce/Ava Tax


On January 1st, 2016, we sunsetted TaxNOW for WooCommerce. To remain on a supported version of WooCommerce, we recommend upgrading to the latest version. The new version will provide you with an improved experience using AvaTax. After the initial installation is complete, future updates will take place automatically, without requiring you to complete these manual download steps. If you used a developer to build customizations to your current version of the connector, you may need to have a developer resource available.