Skip to main content
Avalara Help Center

How do I resolve error message: "No appropriate forms are enabled for this role" in NetSuite OneWorld?

Overview

When Upgrading from the Avalara NetSuite Basic Bundle to the Avalara NetSuite One World Bundle I receive the error message of "No Appropriate forms are enabled for this role" in NetSuite OneWorld but not with NetSuite Basic.

Environment

NetSuite OneWorld

Resolution

  • When upgrading from NetSuite Basic to NetSuite OneWorld you must first uninstall the NetSuite Basic Bundle before attempting to install the Avalara NetSuite OneWorld Bundle.  If you have both Basic and One World running simultaneously this may cause user role issues inside of NetSuite OneWorld.

  •  If you receive this error and have both Basic and One World installed at the same time please uninstall both Avalara NetSuite Bundles and then reinstall the Avalara NetSuite OneWorld Bundle

  • If you are still receiving this error after this process, please log out and log back into Netsuite making sure that all tabs of Netsuite are closed.