Skip to main content
Avalara Help Center

What do I need to do to use TLS?

Overview

You want to know if you need to change anything in your configuration to use Transport Layer Security (TLS) rather than SSL.

Environment

AvaTax Integrations

Resolution

  • Avalara's connectors are equipped to auto-negotiate using TLS.  You don't need to change anything in your systems in order to use a TLS connector.
  • NOTE: Apple, Google, Microsoft and Mozilla will disable Transport Layer Security (TLS) 1.0 and 1.1 support in their respective browsers in the first half of 2020. 
    • The primary AvaTax endpoint supports TLS 1.2, 1.1, and 1.0 (1.1 and 1.0 until deprecation in first half of 2020).
    • If your connector supports TLS 1.2 they should be able to negotiate over security protocol without any issues. Please use TLS 1.2 as your default.