Skip to main content
Avalara Help Center

Error Failed Opening required...SoapClient.class.php

Overview


PHP Fatal error: 
require_once() [<a href='function.require'>function.require</a>]: 
Failed opening required 

Server\HTTPServer\..\avalara\AvaTax4PHP/classes/Avalara/BaseSvc/SoapClient.class.php' 
(include_path='.; 

 

Environment


PHP

SDK

Resolution

 

SSL and SoapClient support is a requirement for access to AvaTax SOAP web service and must be enabled for your PHP interpreter. For windows, add the following extent ions to php.ini:

extension=php_soap.dll
extension=php_openssl.dll

For *nix, it may be necessary to recompile your PHP interpreter with soap.dll and openssl.dll enabled.

See the readme file located here https://github.com/avadev/AvaTax-Calc-SOAP-PHP for more information.