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Avalara Help Center

Why can't I click save when adding nexus to a new company?

Overview

I can't select save when trying to add nexus for a new company.

Environment

Avalara Avatax

Resolution

Please log out and clear your browser cache. 
Log back into the admin console.
Proceed to add and save nexus.

Cause

Browser cache was creating issues with the admin console.

 

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