Skip to main content
Avalara Help Center

Why am I receiving a 'Doc Status is Invalid' error in ECC Webgility and how do I resolve it?

Overview

Receiving a 'Doc Status is Invalid' error when attempting to post certain invoices

Environment

Avalara Avatax

ECC Webgility

Resolution

  • Alter the transaction number in ECC Webgility to a unique value

 

Note: In cases where existing transactions in the Avalara AvaTax are test data or match un-posted transactions in ECC Webgility, do the following

  • Locate the documents in the Admin Console Transactions Tab
  • Save the documents as Uncommitted
  • Repost transactions in ECC Webgility 

Cause

This error occurs when there is already a transaction in the Admin Console with the same Document Code as the Document Code that is attempting to be passed over